Unable to purge package because package is installed? | pressku.com

Trending 4 months ago

I americium trying to instal msodbcsql17 which I did antecedently person installed, but nan work was not installed for immoderate reason, truthful I tried to reconfigure it, but that did not activity truthful I uninstalled it on pinch mssql-tools

hutber@hutber-mint:~$ sudo apt-get instal msodbcsql17 Reading package lists... Done Building dependency tree... Done Reading authorities information... Done The pursuing NEW packages will beryllium installed: msodbcsql17 0 upgraded, 1 recently installed, 0 to region and 0 not upgraded. Need to get 0 B/749 kB of archives. After this operation, 0 B of further disk abstraction will beryllium used. Preconfiguring packages ... (Reading database ... 723187 files and directories presently installed.) Preparing to unpack .../msodbcsql17_17.10.5.1-1_amd64.deb ... Installation failed, ODBC Driver 17 for SQL Server detected! dpkg: correction processing archive /var/cache/apt/archives/msodbcsql17_17.10.5.1-1_amd64.deb (--unpack): caller msodbcsql17 package pre-installation book subprocess returned correction exit position 1 Errors were encountered while processing: /var/cache/apt/archives/msodbcsql17_17.10.5.1-1_amd64.deb E: Sub-process /usr/bin/dpkg returned an correction codification (1)

I judge this correction occured erstwhile I ran sudo dpkg-reconfigure msodbcsql17 which ended up with:

odbcinst: Driver installed. Usage count accrued to 2. Target directory is /etc hutber@hutber-mint:~$ sudo apt-get region --purge msodbcsql17 Reading package lists... Done Building dependency tree... Done Reading authorities information... Done Package 'msodbcsql17' is not installed, truthful not removed You mightiness want to tally 'apt --fix-broken install' to correct these. The pursuing packages person unmet dependencies: mssql-tools : Depends: msodbcsql17 (>= 17.3.0.0) but it is not going to beryllium installed E: Unmet dependencies. Try 'apt --fix-broken install' pinch nary packages (or specify a solution). hutber@hutber-mint:~$ sudo apt --fix-broken install Reading package lists... Done Building dependency tree... Done Reading authorities information... Done Correcting dependencies... Done The pursuing further packages will beryllium installed: msodbcsql17 The pursuing NEW packages will beryllium installed: msodbcsql17 0 upgraded, 1 recently installed, 0 to region and 0 not upgraded. 1 not afloat installed aliases removed. Need to get 0 B/749 kB of archives. After this operation, 0 B of further disk abstraction will beryllium used. Do you want to continue? [Y/n] Preconfiguring packages ... (Reading database ... 723201 files and directories presently installed.) Preparing to unpack .../msodbcsql17_17.10.5.1-1_amd64.deb ... Installation failed, ODBC Driver 17 for SQL Server detected! dpkg: correction processing archive /var/cache/apt/archives/msodbcsql17_17.10.5.1-1_amd64.deb (--unpack): caller msodbcsql17 package pre-installation book subprocess returned correction exit position 1 Errors were encountered while processing: /var/cache/apt/archives/msodbcsql17_17.10.5.1-1_amd64.deb E: Sub-process /usr/bin/dpkg returned an correction codification (1)

So, really tin I wholly region this package? I consciousness for illustration I person created immoderate weird information dependency thing

More
close