ubuntu 22.04 on iMac 2012 - 27" - external screen not detected - nvidia?

Trending 2 months ago

I americium moving Ubuntu 22.04 connected an iMac 2012 fusion thrust - to my awesome satisfaction. (Dual footwear pinch OSX / MacOs Catalina)

The only problem I person is that I tin not get an outer 27" show to beryllium detected. The outer show does activity connected MacOs Catalina.

Does anybody person a clue?

Here are nvidia related entries from journalctl:

  • kernel: audit: type=1400 audit(1707066852.384:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe" pid=492 comm="apparmor_parser"
  • kernel: audit: type=1400 audit(1707066852.384:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe//kmod" pid=492 comm="apparmor_parser"
  • audit[492]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe" pid=492 comm="apparmor_parser"
  • audit[492]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe//kmod" pid=492 comm="apparmor_parser"
  • kernel: input: HDA NVidia HDMI/DP,pcm=3 arsenic /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input10
  • kernel: input: HDA NVidia HDMI/DP,pcm=7 arsenic /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input11
  • kernel: input: HDA NVidia HDMI/DP,pcm=8 arsenic /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input12
  • kernel: input: HDA NVidia HDMI/DP,pcm=9 arsenic /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input13
  • /usr/libexec/gdm-x-session[1156]: (II) NOUVEAU driver for NVIDIA chipset families :
  • /usr/libexec/gdm-x-session[1156]: (II) config/udev: Adding input instrumentality HDA NVidia HDMI/DP,pcm=3 (/dev/input/event4)
  • /usr/libexec/gdm-x-session[1156]: (II) config/udev: Adding input instrumentality HDA NVidia HDMI/DP,pcm=7 (/dev/input/event11)
  • /usr/libexec/gdm-x-session[1156]: (II) config/udev: Adding input instrumentality HDA NVidia HDMI/DP,pcm=8 (/dev/input/event12) /usr/libexec/gdm-x-session[1156]: (II) config/udev: Adding input instrumentality HDA NVidia HDMI/DP,pcm=9 (/dev/input/event13)
  • /usr/libexec/gdm-x-session[1646]: (II) NOUVEAU driver for NVIDIA chipset families :
  • /usr/libexec/gdm-x-session[1646]: (II) config/udev: Adding input instrumentality HDA NVidia HDMI/DP,pcm=3 (/dev/input/event4)
  • /usr/libexec/gdm-x-session[1646]: (II) config/udev: Adding input instrumentality HDA NVidia HDMI/DP,pcm=7 (/dev/input/event11)
  • /usr/libexec/gdm-x-session[1646]: (II) config/udev: Adding input instrumentality HDA NVidia HDMI/DP,pcm=8 (/dev/input/event12)
  • /usr/libexec/gdm-x-session[1646]: (II) config/udev: Adding input instrumentality HDA NVidia HDMI/DP,pcm=9 (/dev/input/event13)
  • gdm3[2571]: modprobe: FATAL: Module nvidia not recovered successful directory /lib/modules/6.5.0-15-generic
  • gdm3[3285]: modprobe: FATAL: Module nvidia not recovered successful directory /lib/modules/6.5.0-15-generic
  • gdm3[3473]: modprobe: FATAL: Module nvidia not recovered successful directory /lib/modules/6.5.0-15-generic

Current NVIDIA config:

nvidia

lshw output:

lshw output

System Profiler bid connected MacOs (same machine) :

System Profiler bid MacOs

Then I bought a caller cable, a bully one. On MacOs, I person now a cleanable view.

External MacOs - bully cable

But Ubuntu still does not admit nan outer display.

I tried different driver, nan "nouveau". But that killed my graphical environment. Searched for 1 hour. Needed to repair it via

sudo ubuntu-drivers autoinstall

ignore nan errors, reboot, and OK. Thanks to linuxbabe.

UPDATE !!!

When I update nan driver to nan nouveau driver via bid line, Ubuntu starts up OK aft a reboot.

apt-get instal xserver-xorg-video-nouveau

But.... erstwhile I update nan driver to nan nouveau driver via nan Ubuntu settings screen, (see above), past Ubuntu graphical env. does not commencement up. And past I besides spot thing strange, I deliberation it is related to nan outer show :

lshw -c display

nouveau driver via ubuntu

New update 1:

I besides tested an iMac 2010 pinch ATI Radeon card, that is moving pinch nan 2nd monitor.

ATI Radeon

** New update 2:** I besides tested nan imac 2012 pinch a Fedora unrecorded USB, that is moving pinch nan 2nd show too. But it is moving Wayland. Let see.... support you posted.

** NEW UPDATE - nan saga continues....**

After yesterdays Fedora Live USB, I tested besides pinch a unrecorded USB from Mint, and installed them both.

In each cases, Linux seems to “think” nan outer show is moving fine, since my windows and rodent vanish into nan achromatic outer surface each erstwhile successful a while. That surface is besides visible successful show setup.

In a past try, I downloaded a marque caller Ubuntu 22 (11 feb 2024), conscionable to person a bully cleanable system. And gues what ….

IT WORKED consecutive retired of nan box!

But ….

Only 10 minutes, earlier nan reboot. This was precisely what I feared, considering nan “after installation processes”.

So I made immoderate screenshots and notes BEFORE THE REBOOT.

NVIDIA earlier reboot Display settings earlier reboot 2 displays working

Check nan different result from nan nvidia instrumentality AFTER THE REBOOT:

NVIDIA 1 aft reboot

NVIDIA 2 aft reboot

I americium lost, this takes excessively overmuch of my clip currently. Will get backmost to this later.

Cheers

Pla

More
close