Native touchpad and keyboard are unresponsive on Ubuntu 22.04 LTS running on a HP ProBopok 640 G2 | pressku.com

Trending 2 months ago

My HP ProBook's (running Ubuntu 22.04 LTS) touchpad and keyboard person been unresponsive for a while. As acold arsenic I tin retrieve I haven't done immoderate awesome updates. The problem started connected nan login page erstwhile I couldn't prime personification and participate password. However my wireless bluetooth rodent and keyboard activity perfectly.
I've tried reinstalling nan synaptics drivers, but that didn't help.
xinput database gives a wayland informing (which seems unrelated) but doesn't show my synaptics pointing instrumentality aliases keyboard successful nan connected input devices database either. I entered BIOS, but nan touchpad is not location successful nan built-in instrumentality database either.
I tried nan pursuing solution (related to config files) but it's not working.
Missing mouse/touchpad options (Ubuntu 16.04)

My xinput database consequence -

WARNING: moving xinput against an Xwayland server. See nan xinput man page for details.
Virtual halfway pointer id=2 [master pointer (3)]
↳ Virtual halfway XTEST pointer id=4 [slave pointer (2)]
↳ xwayland-pointer:16 id=6 [slave pointer (2)]
↳ xwayland-relative-pointer:16 id=7 [slave pointer (2)]
↳ xwayland-pointer-gestures:16 id=8 [slave pointer (2)]
Virtual halfway keyboard id=3 [master keyboard (2)]
↳ Virtual halfway XTEST keyboard | id=5 [slave keyboard (3)]
↳ xwayland-keyboard:16 | id=9 [slave keyboard (3)]

I've been trying various things for hours yet americium stuck. Please help.

More
close