Dependency issue when trying to install gcc13 and g++13 | pressku.com

Trending 2 months ago

I person been trying to instal gcc-13 and g++-13 successful bid to person entree to nan afloat scope of features successful C++20.I person been moving into a dependency rumor that doesn't make consciousness arsenic nan sub-package causing nan rumor is installed astatine a higher type than what is required.

After upgrading my packages via

sudo apt update

sudo apt upgrade

sudo apt autoremove --purge

There are 16 packages that are not upgraded. I person besides added nan trial repo for nan ubuntu toolchain via

sudo add-apt-repository ppa:ubuntu-toolchain-r/test

When running

sudo apt instal gcc-13 g++-13

I person nan pursuing error

The pursuing packages person unmet dependencies: libgcc-13-dev : Depends: libgcc-s1 (>= 13.1.0-8ubuntu1~22.04) but 12.1.0-2ubuntu1~22.04 is to beryllium installed E: Unable to correct problems, you person held surgery packages.

To effort to resoluteness this I americium running

sudo apt instal libgcc-s1

Which results in

The pursuing packages person unmet dependencies: libcrypt1:i386 : Depends: libc6:i386 (>= 2.25) but it is not going to beryllium installed E: Error, pkgProblemResolver::Resolve generated breaks, this whitethorn beryllium caused by held packages.

Finally, I americium running

sudo apt instal libc6:i386

But it states

libc6:i386 is already nan newest type (2.35-0ubuntu3.6)

If this type is 2.35-0, past why is location a dependency issue? How do I spell astir resolving this?

More
close